Overview

There are two types of IDM files. IDM 1 and IDM 2. You create IDM 1 files with the After Effects plugin Launch Pad, which is part of Space Tools. You create IDM 2 files with the After Effects plugin Scene Builder, which is part of Scene Tools.


Space Tools → Launch Pad → IDM 1
Scene Tools → Scene Builder → IDM 2


A video can only have one type of IDM files. You can have a video built out of only IDM 1 files, or only IDM 2 files, but no mixing both. To take advantage of new features, you have to use IDM 2 files.

There are several reasons why you'd like to update a video from IDM 1 to IDM 2:

  • You want to use new features such as Rich Text, Effects, Dynamic Scene Duration, and so on.
  • You want your project to render faster.
  • You have a change request and think: "might as well take the opportunity".

If you want to keep using Space Tools, you can still find them on our download page, and carry on updating an old project.
If you want to move forward and enjoy the new features, read on to see how to go about exporting an old project to IDM 2.


Setting Placeholders

As we changed from Launch Pad to Scene Builder, the way we set layers as placeholders has changed as well. When you open a project that used Launch Pad in the past you will be missing the placeholder plugin Launch Pad was using. You are then presented with the After Effects error: "This project contains a reference to a missing effect". As you might have a lot of layers that need to be updated, we have created a script you can use to update all the placeholder layers to the new type. Follow these steps:

  1. Download the Replace Placeholder.jsxbin file from the bottom of this article.
  2. Install the script by placing it in the After Effects scripts folder.
    • Windows: C:\Program Files\Adobe\Adobe After Effects CC <2018>\Support Files\Scripts\
    • Mac OS: /Applications/Adobe After Effects <2018>/Scripts/
  3. Open After Affect, or restart it if it was open.
  4. Open your project and click OK on the error message about missing the IDM Placeholder effect.
  5. Click File > Scripts > Replace Placeholder.jsxbin
    The script looks for all old placeholders and replaces them with new ones.
  6. A message comes up telling you how many placeholders were updated. Close the message.

You have now finished updating the placeholders to the new type. You are ready to move on to the next stage: packaging the project.

To learn more about using script with Adobe After Effects you can follow this article by Adobe.


Packaging Scenes

To re-package your project, the only thing you need to do is, well… re-package your project. Nothing else. There is the added bonus that Scene Builder can package many scenes at once, so things are quicker.

  1. Make sure Scene Builder is loaded. If it's not, find it in Window > Idomoo Scene Builder.
  2. Find the scene compositions in the project panel and multi-select all the ones you want to package.
  3. Scene Builder tells you how many scenes you are about to package to the right of the Package button.
  4. Click the package button and choose a location for the files.
    The names of the files are going to be the names of the compositions. You can always change the names later if you wish.