Idomoo Scene Tools includes two parts:

  1. Scene Builder: the After Effects plugin with which you set placeholders and export IDM scene files.
  2. Scene Viewer: a standalone application that enables previewing IDM scenes. Note that Scene Viewer is only availble for Windows with an NVidia graphics card.


Downloading and Installing

  1. To download the installer, visit the tools download page.
  2. Make sure Adobe After Effects isn't running on your machine.
  3. Double click the installer and follow the instructions.
  4. You will have to do certain things manually, so please keep on reading.


Note:

  • Installing applications requires an administrator password, so be sure you are logged on as an administrator.
  • If you had Idomoo's previous suite of tools—Space Tools, installed, make sure to remove them. You can consult this Idomoo Academy article about it.
  • If you want to upgrade a project from Space Tools to Scene Tools follow this article.


Loading Scene Builder

  1. Launch After Effects.
  2. In After Effects, click Window > Idomoo Scene Builder.

This launches Scene Builder as a floating panel. You can dock the panel anywhere in the interface.


Loading Output Modules

As Scene Builder writes files to disk, it needs several Output Module templates loaded before you can use it:

  1. Click Edit > Templates > Output Module.
  2. In the bottom left corner, click Load.
  3. In the file browser that opens, navigate to the extras folder in the install location. By default this is C:\Program Files\Idomoo Scene Tools\Extras, or /Applications/Idomoo Scene Tools/Extras on the Mac.
  4. Double click Idomoo Video.aom.
  5. An error message appears saying some modules didn't load. Ignore the error by clicking OK.
  6. Click OK to close the Output Modules panel.



Next Using Scene Builder
Back Placeholder Behavior



Using Scene Viewer with a Dual Graphic Card System

Sometimes when using a system with both an integrated graphics card and an NVidia graphics card, Scene Viewer defaults to using the integrated graphics card instead of the NVidia one. To fix this issue please follow these steps:

  1. While the windows desktop is visible, right-click in an empty part of the desktop.
  2. Click NVidia Control Panel.
  3. From the left menu click Manage 3D Settings.
  4. Click the Program Settings tab.
  5. Click Add and double click C:\Program Files\Idomoo Scene Tools\SceneViewer\SceneViewer.exe
    Note that if you installed Scene Viewer in a different location this path will be different.
  6. From the Preferred Graphics Processor drop-down menu click High-Performance NVidia processor.
  7. Click Apply.

Scene Viewer should now be using the NVidia card instead of the integrated graphics card.




Uninstalling Scene Tools


Removing the Output Module

During installation, more output modules are added to the Output Modules template list. Here's how to remove them:

  1. Make sure After Effects is open.
  2. Click > Edit > Templates > Output Module.
  3. From the drop-down menu, choose idomoo video 2.0.
  4. Click the Delete button.
  5. Repeat for the Idomoo audio and Idomoo still output modules.
  6. Click OK to close the Output Modules panel.

You have removed the Idomoo output module.


Uninstalling

Make sure After Effects is shut down, then uninstall depending on your operating system.

Mac:

  1. In the Finder, navigate to the install location. By default this is /Applications/Idomoo Scene Tools/.
  2. Double click Uninstall.app and follow the instructions.

Windows:

  1. Click the start menu and type Remove.
  2. Click Add or Remove Programs.
  3. In the program list click Scene Tools > Uninstall, and follow the instructions.

Note that uninstalling an application requires an administrator password, so be sure you are logged on as an administrator.