Here are the system requirements for the three Idomoo products:

Scene Builder

This Adobe After Effects plugin requires the following:

  • Windows 7, Windows 8, Windows 10, (64bit only) or
    OS X 10.9.5 and higher
  • 4 GB RAM (minimum)
  • After Effects CC 2015 (version 13.5) or through to After Effects 2018 (version 15), updated to the latest version.


Idomoo Scene Viewer

This standalone IDM file preview application requires the following:

  • Windows 7, Windows 8, Windows 10 (64bit only)
  • 4 GB RAM (minimum)
  • Dedicated NVIDIA graphics card with OpenGL 4.3 support or above
  • Latest NVIDIA drivers installed


Idomoo StoryBuilding Suite

StoryBuilding Suite web services requires the following:

  • Minimum screen resolution 1100 pixels wide
  • Updated versions of the following browsers:
    • Firefox
    • Chrome
    • Safari
    • Internet Explorer 9-11
    • Safari for iOS
  • We constantly test the two latest browser versions for each of the five browsers listed above. If your browser is up to date, it should work well with Idomoo StoryBuilding Suite.


Only have Macs?

At the moment only Scene Builder is available for the Mac. Instead of using Scene Viewer to preview your scene, simply upload the IDM file to the StoryBuilding Suite and test it there.