See System Requirements here.



Scene Tools 2.2.3 Release Notes

Including Scene Builder 2.3.3 & Scene Viewer 2.2.8
Release Date | June 18th, 2019

General

With this version of Scene Tools we're thrilled to release our first version of the effect IDM Layer Styles. This is a replacement to Adobe's own Layer Styles. This first version supports only a small subset of the full list of featured available through Adobe's version of Layer Styles, but more will follow.

Scene Builder

New Features

  • Scene Builder will not allow for an IDM to be created with an asset, for example, an image file, with a file name that contains unsupported characters. The supported characters are: a-z A-Z 0-9 _ . - and a space.
  • The baseline shift parameter in After Effect's character panel is not supported. Trying to mark a layer using this property as a placeholder now results in an error.
  • Looking in the properties of a text layer, there's a whole sub-menu called "more options". We only support the default state of the properties in this section. Changing any of the properties will result in a error message when trying to set the layer as a placeholder.
  • On rare occasions Scene Builder is prevented from setting "Idomoo Video 2.0" as the output module when packaging a scene. When that happens you now get an error message explaining this. If that happens you should set that output module as default by clicking Edt > Templates > Output Module and changing the Movie Default drop-down menu to "Idomoo Video 2.0".

Bug Fixes

  • Some expressions used on the Opacity property of a layer, the more complex ones, didn't translate properly to the IDM. Now they do.
  • If the user name for logging into your computer had specialized characters in it, like š, the packaging process wouldn't have worked. We like being inclusive to all our users, so we fixed this. Sorry Matouš.
  • Using two text animators didn't work. Now it does. Go to town on those animators!
  • When using unsupported text animate features on a Mac the error messages received were quite obscure. We fixed that now.
  • If a text layer had a text animator turned off, the text animator would still be exported. This is no longer the case.
  • Text animators that use expressions to drive animation, instead of keyframes, are resolved as well now. Didn't before. Now they do.
  • Clicking Stop to stop a render during packaging, stops the packaging process.


Effects

New Features

  • Layer Styles: the first iteration of layer styles is ready. It includes:
    • Color Overlay
    • Stroke
  • Read more here.

Render Engine

Bug Fixes

  • Some minor mask related bugs fixed.



Scene Tools 2.1.12 Release Notes

Including Scene Builder 2.2.9 & Scene Viewer 2.1.10
Release Date | January 9th, 2019

General

The main reason for this version is to support After Effects CC 2019 (also known as version 16.0). Some small bugs and enhancements also made it in to this version.

Render Engine

Bug Fixes

  • In a text placeholder with shrink used, the baseline shift used in superscript was not shrunk and text appeared higher than it should. We thought you might want that fixed, so we did.
  • Images and videos some times appeared unexpectedly rotated by 90-270 degrees. We don't like unexpected things happening so we fixed this one.


Scene Builder

New Features

  • Installs on After Effects CC 2019 (also known as version 16.0).

Bug Fixes

  • If the second line of text in a text layer was empty, the leading calculated by Scene Builder was wrong. We did better math. Now it's working as you'd expect.


Effects

New Features

  • IDM Corner Pin: copy button added to interface to copy from one set of points to the other.

Scene Viewer

New Features

  • Scene Viewer doesn't allow to use images larger than the allowed maximum size of 2048 x 2048.



Scene Tools 2.1 Release Notes

Including Scene Builder 2.2 & Scene Viewer 2.1
Release Date | April 11th, 2018

General

This is the second iteration of Scene Tools—our suite of tools that replaces Space Tools. If this is the first version of Scene Tools you are using, scroll down and read about all the new things—and there are a lot. Specifically read the note about backward compatibility.

Scene Builder

New Features

  • Text Animate is now supported with the Range selector and these properties:

    • All Transformation Properties (2D only)
    • Line Spacing
    • Tracking
    • Character Offset (character range > full unicode)
    • Character Value (character range > full unicode)
    • Fill Color (RGB only)
  • A layer with video footage can now be defined as a placeholder
  • Track matte pairs consisting of a placeholder layer and a static comp are now supported in any combination. You can't have two static comps in a track matte pair in a Scene comp. You can simply pre-comp them to circumvent this
  • IDM Corner Pin now has a motion blur setting
  • IDM files are better compressed now resulting in smaller file sizes

Bug Fixes

  • Video assets sent during render with Idomoo that had a different FPS then the scene were not converted to the correct frame rate. Now they are
  • Audio layers marked as a placeholder were getting distorted. This is no longer the case
  • System Info on Mac now works. Find it by clicking the idomoo icon on the panel
  • Vector mask rendering got several tweaks that fixed several bugs where the masks appeared in wrong places


Scene Viewer

New Features

  • Support MP4 and FLV assets for media placeholders assets
  • Viewer alpha button added to show the alpha, in case the scene renders with transparency

Bug Fixes

  • General bug fixes



Scene Tools 2.0 Release Notes

Including Scene Builder 2.1 & Scene Viewer 2.0
Release Date | September 17th, 2017

General

This release is a major update to the Idomoo platform. So many parts of the platform have changed that we are calling it Idomoo PVaaS 2.0 (Personal Video as a Service 2.0). Every aspect of the platform has been upgraded and with it you will feel a nice speed hike, more stability, reliability, and, a plethora of new features coming your way.

Name Change

You might have already noticed that we changed the name of the tools suite from Space Tools to Scene Tools. This is to reflect the purpose of this suite of tools – to generate IDM scene files. You will also notice that Launch Pad is now called Scene Builder and Space Viewer is now called Scene Viewer. To summarise:

Space Tools>Scene Tools
Launch Pad>Scene Builder
Space Viewer>Scene Viewer

Backward Compatibility

The IDMs generated using Scene Builder are not compatible with IDMs generated with Launch Pad. They can both be uploaded to our Storybuilding Suite and used in a Storyboard, but not together. Storyboards must contain only one type of IDM, either all old, or all new.

You will always be able to download the latest version of Space Tools so you can maintain older projects. However, to gain new features, you will need to upgrade your whole scene library to Scene Tools IDM files.

Scene Builder

New Features

  • Support for After Effects CC 2014 has been dropped
  • Better error messages – When trying to set a placeholder or package a scene the errors you now get are more descriptive. Also, you get all of them at once and can copy the list of errors so you can go through them one by one.
  • Packaging speed – The time it takes for a project to be packaged has been significantly reduced.
  • Better quality – The quality of static comps output has been improved. This can increase the size of the IDM files in some cases.
  • Packaging multiple scenes – You can now package multiple scenes at once by selecting them in the Project panel and clicking the Package button. After all errors are fixed you are presented with a file browser. Choose where to save the IDM files. You will not get to choose how they are called, though. Instead they will automatically be called: _. Each scene will be made into a single IDM file.
  • Renaming IDM files – Renaming IDM files after creation is now possible.
  • Any resolution - Scene comps are no longer limited to a set list of resolutions. You can set your scene comps to any resolution up to a maximum of 1920 x 1920. Please note that the bigger the resolution of the IDM, the slower the render. This can have a major effect on real-time projects.
  • Placeholder layer naming – There are no longer limits to how you name a layer. You can use any text.
  • Audio placeholder support – You can now set an audio layer as a placeholder. The start and end time of the audio is noted, as well as volume. The placeholder will then appear in the Storybuilding Suite just like images and text placeholder do.
  • Solid placeholder support – You can now set a solid layer as a placeholder. It acts exactly the same as an image placeholder. Color (what we call solid) and image placeholders are interchangeable. You can replace the content of a color placeholder with an image and vice-versa.
  • Effects! – The Scene Tools installer installed two Idomoo effects in the Idomoo Effects folder. These are IDM Corner Pin and IDM Gaussian Blur. You can now use these effects, but only these effects. Using them is pretty easy as they are our versions of the equivalent Adobe effects. Please keep in mind that if render speed is a concern for your project, for example, for projects that need to be generated in real-time, using blur-based effects slows down render considerably.
  • Blending modes – Placeholder layers and static comps are no longer limited to the Normal blending mode. Aside from normal, you can now use the blending modes between Darken and Luminosity.
  • Track Matte support – You can now hold a placeholder inside another placeholder. You still can't hold a placeholder inside a static comp.
  • Parenting – Parenting is no longer limited to just null objects. You can parent a layer to another layer as well.
  • Motion blur settings – Up to now, motion blur, which is generated by animating a layer, was limited to the default settings only. You can now render with any settings. You do that in Composition Settings > Advanced.
  • Font file formats – More font file formats are now supported. These are: TTF, TTC, OTF, OTC, PFA, PFB, DFONT and Adobe TypeKit.
  • Paragraph text support – You can now use paragraph text layer as well as point text layers for placeholder layers.
    The bounding box for a paragraph text layer is the box you can set when the actual text is being edited, not the box generated when you stop editing the text.

    When using a point text layer, the text shrinks when reaching the width of the bounding box. When using a paragraph text layer, the text starts a new line when reaching the width of the bounding box.
  • Text tracking support – Tracking, the distance between characters set in the character panel, is now supported. Please note that kerning remains unsupported.

    Despite that in After Effects you can set a different tracking value for each character, only a single value can be set for the whole layer when using the layer as a placeholder.
  • Text leading support – Leading, the distance between lines of text, is now supported. Despite that in After Effects you can set a different leading value for each line, only a single value can be set for the whole layer when using the layer as a placeholder.

Bug Fixes

  • This is a completely new version of Scene Builder. There are no known bugs as of yet.


Scene Viewer

New Features

  • IDM support – Scene Viewer supports only new IDM files generated with Scene Builder. It does not support opening IDM files generated with Launch Pad.
  • Ranged playback – There are new buttons in the interface allowing for ranged playback. You can set an in point for playback by pressing I on the keyboard, and end point by pressing O. You then press the Ranged Playback button, shown in the image below, to play only that range.

Bug Fixes

  • Small maintenance bug fixes.



Space Tools 1.2.8 Release Notes

Including Launch Pad 1.9.0 & Space Viewer 1.2.2
Release Date | May 10th, 2017

Launch Pad

New Features

  • No new features.

Bug Fixes

  • Reduced size of IDM files.



Space Tools 1.2.4 Release Notes

Including Launch Pad 1.8.7 & Space Viewer 1.2.2
Release Date | March 16th, 2017

Launch Pad

New Features

  • Added support for the following resolution: 1080 X 1080.
  • Improved quality of static layers

Bug Fixes

  • Small maintenance bug fixes.



Space Tools 1.2 Release Notes

Including Launch Pad 1.8 & Space Viewer 1.2
Release Date | November 15th, 2016

Launch Pad

New Features

  • Added support for Adobe Creative Cloud 2017

Bug Fixes

  • Small maintenance bug fixes.

Space Viewer

New Features

  • Added a Back to Default button, so you can easily revert your data to what you have in the IDM. It looks like this:
  • Added an On/Off button so you can turn off a layer if you need to. It looks like this:



Space Tools 0.9 Release Notes

Including Launch Pad 1.7 & Space Viewer 1.1
Release Date | August 7th, 2016

Launch Pad

New Features

  • The largest image size used for placeholder is 2048x2048, however, if a mask is added to the image, then the largest image can only be 1950x1950.

Bug Fixes

  • We hope we finally managed to fix the Launch Pad update checker on the Mac.
  • Small maintenance bug fixes.

Space Viewer

Bug Fixes

  • Small maintenance bug fixes.



Space Tools 0.8.2 Release Notes

Including Launch Pad 1.5.1 & Space Viewer 0.8.2
Release Date | May 26th, 2016

General

  • Dynamic videos are now supported. You still define an image in After Effects, but that image can be replaced with video during video generation.

Launch Pad

New Features

  • The resolutions 1920x1080, 1280x720, 720x1280 and 640x360 are now supported for scene comps.
  • Any FPS (frames per second) is now supported up to 30.

Bug Fixes

  • Masks on two or more lines of text were being shifted. This has been fixed.
  • We hope we finally managed to fix the Launch Pad update checker.

Space Viewer

New Features

  • You can now resize the Space Viewer window.



Space Tools 0.7.5 Release Notes

Including Launch Pad 1.0.3.8 & Space Viewer 0.7.5
Release Date | April 17th, 2016

General

  • Launch Pad now available for Mac.

Launch Pad

New Features

  • The 1920x1080 resolution is now supported for scene comps.
  • Launch Pad now checks periodically to see if there's a new release and notifies with an alert.

Bug Fixes

  • Masks with feathering on text placeholder layers produced problematic results. They now work perfectly.

Space Viewer

Bug Fixes

  • Space Viewer won't let images larger than 2048x2048 (the maximum size for dynamic images) to be used anymore.



Space Tools 0.7.4 Release Notes

Including Launch Pad 1.0.3.7 & Space Viewer 0.7.4
Release Date | March 21st, 2016

General

  • When rendering final videos through batch or API the quality has received a much needed bump.
  • The render speed has increased when rendering final videos through batch or API.
  • Multi-line spacing now matches After Effects' "Auto" leading.

Launch Pad

New Features

  • Expressions are now supported and don't need to be pre-converted to keyframes.
  • The quality for static layer renders has been increased. This also results in bigger size IDM files.
  • Font panel changed:
    • Font choice removed. The font is now chosen automatically.
    • The language choice has been changed from a drop down menu to a full choice menu. The choice is per script rather than per language. For example, for languages using the Roman script, such as English, Spanish, French and so on, are held under Roman. The full list now is Roman, Arabic, Chinese, Cyrillic, Greek, Hebrew, Japanese, Korean, and Thai.
  • "Open in Space Viewer" button added to the alert at the end of a successful packaging operation.

Bug Fixes

  • Various mask issues were fixed. A few small issues are still pending.
  • Several obscure transformation bugs were fixed.
  • Invisible nulls are now exported and don't raise an error.
  • Added a check for the existence of the Idomoo Video Output Module. Package will stop if Output Module is missing.

Space Viewer

New Features

  • Save Screenshot was moved from the Help menu to the File menu.
  • Multi-line text now appears as multi-lines by default in the placeholder list on the left side of the interface.

Bug Fixes

  • The green bounding-box graphic now shows the exact bounding-box, as it was defined in After Effects.


p>


 Next Using Idomoo Scene Tools to Package and Preview a Scene 
 Back Scene Tools System Requirements